加入收藏
 

回归主图改进文本格式 通达信主图指标 源码 贴图 无未来

2019-01-17 10:21:01推荐星级:下载统计()
奇爱股票网提供回归主图改进文本格式 通达信主图指标 源码 贴图 无未来下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

回归主图改进文本格式 通达信主图指标 源码 贴图 无未来说明

回归主图改进文本格式 通达信主图指标 源码 贴图 无未来

回归线:=EMA(SLOPE(C,4)*20+C,42);

R:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K1:=SMA(R,3,1); D1:=SMA(K1,3,1); J1:=3*K1-2*D1;


MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))) /(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));
MAHL2:=IF(EMA(C,2)>回归线 AND MAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}
MAHL3:=IF(EMA(C,2)>回归线 AND MAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}
回归带:DRAWBAND(回归线,RGB(235,0,230),REF(回归线,2),RGB(0,104,154));

上线:=SMA(C,6.5,1);
一号支撑线:SMA(C,14.5,1);
上线1:=SMA(C,3,1);
一号支撑线1:=SMA(C,8,1);
上线2:=SMA(C,3.5,1);
DRAWTEXT(CROSS(一号支撑线1,上线1),H*1.08,'洗盘'),COLOR00FF00;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;
UPR:=BBI+3*STD(BBI,13),LINETHICK2;
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,55),LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT( CROSS(82,RSI) AND CLOSE<上线1 , HIGH*1.04,'减仓') ,COLORFF9966,LINETHICK2;
A7:=(2*C+H+L)/4;
操作:MA(A7,5),COLORBLUE,LINETHICK2;
操作1:=MA(A7,5)*1.03,LINETHICK2;
操作2:=MA(A7,5)*0.97,LINETHICK2;


YCX:=操作>=REF(操作,1);
H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);
L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);
DRAWTEXT(CROSS(上线1,一号支撑线1) AND 上线1>操作 ,LOW *0.98,'全仓' ),COLORYELLOW;


M1:=1000*操作/一号支撑线<=1015 AND 1000*操作/一号支撑线>=975;
M2:=1000*一号支撑线1/一号支撑线<=1020 AND 一号支撑线1/一号支撑线>=980;
M3:=1000*上线/一号支撑线<=1015 AND 上线/一号支撑线>=985;

{业绩综合}
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));

{风险系数}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
DRAWTEXT_FIX(ISLASTBAR,0.46,100,0,财务系数),COLORGRAY;

DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLORCYAN;
DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLORCYAN;
DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.30,0.00,0,'主题投资:'),COLORCYAN;
DRAWTEXT_FIX(1,0.36,0.00,0,EXTERNSTR(0,2)),COLORLIRED;
DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:')COLORCYAN;
DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3)),COLORRED;

DRAWTEXT_FIX(1,0.00,0.15,0,'莸利比例:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.06,0.15,0,CONST(WINNER(C )*100)),COLORWHITE;
DRAWTEXT_FIX(1,0.12,0.15,0,'动态PE:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.17,0.15,0,CONST(DYNAINFO(39))),COLORWHITE;
DRAWTEXT_FIX(1,0.22,0.15,0,'市值:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.26,0.15,0,FINANCE(40)/100000000),COLORWHITE;
DRAWTEXT_FIX (1,0.31,0.15,0,'公积金(股):'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.38,0.15,0,FINANCE(18)),COLORWHITE;
DRAWTEXT_FIX (1,0.43,0.15,0,'收益:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.47,0.15,0,FINANCE(33)),COLORWHITE;

{财务分折}
DRAWTEXT_FIX(1,0.00,100,0,'财务分折:')COLORMAGENTA;
DRAWTEXT_FIX(1,0.08,100,0,'现金流:'),COLOR00CCCC;
DRAWNUMBER_FIX(1,0.14,100,0,CONST(FINANCE(25)/1000000000)),COLOR00CCCC;
DRAWTEXT_FIX(1,0.2,100,0,'流动比率:'),COLOR00CCCC;{流动比率值>1.5<2.5较为合理,低于1说明偿债能力欠佳。}
DRAWNUMBER_FIX(1,0.27,100,0,CONST(FINANCE(11)/FINANCE(15))),COLOR00CCCC;
DRAWTEXT_FIX(1,0.33,100,0,'速动比率:'),COLOR00CCCC;
DRAWNUMBER_FIX(1,0.4,100,0,CONST((FINANCE(11)-FINANCE(27))/FINANCE(15))),COLOR00CCCC;

VAR31:=HHVBARS(ZIG(3, 19)>REF(ZIG(3,19),1)
AND REF(ZIG(3,19), 1)<REF(ZIG(3,19), 2),0);
STICKLINE(VAR31=2,L*0.95,L*0.98,2,0),COLOR0000FF;
DRAWTEXT(VAR31=2,L*0.95,'3天'),COLORYELLOW;
STICKLINE(VAR31=4,H*1.05,H*1.02,2,0),COLOR9966FF;
DRAWTEXT(VAR31=4,H*1.06,'5天'),COLORYELLOW;
STICKLINE(VAR31=7,L*0.95,L*0.98,2,0),COLOR00FFFF;
DRAWTEXT(VAR31=7,L*0.95,'8天'),COLORYELLOW;
STICKLINE(VAR31=12,H*1.05,H*1.02,2,0),COLORFF33FF;
DRAWTEXT(VAR31=12,H*1.06,'13天'),COLORYELLOW;
STICKLINE(VAR31=20,L*0.95,L*0.98,2,0),COLOR0066FF;
DRAWTEXT(VAR31=20,L*0.95,'21天'),COLORYELLOW;
STICKLINE(VAR31=33,H*1.05,H*1.02,2,0),COLORFFFF00;
DRAWTEXT(VAR31=33,H*1.06,'34天'),COLORYELLOW;
STICKLINE(VAR31=54,L*0.95,L*0.98,2,0),COLOR006600;
DRAWTEXT(VAR31=54,L*0.95,'55天'),COLORYELLOW;
STICKLINE(VAR31=88,H*1.05,H*1.02,2,0),COLOR00FF00;
DRAWTEXT(VAR31=88,H*1.06,'89天'),COLORYELLOW;
STICKLINE(VAR31=143,L*0.95,L*0.98,2,0),COLORCCFFFF;
DRAWTEXT(VAR31=143,L*0.95,'144天'),COLORYELLOW;
STICKLINE(VAR31=232 ,H*1.05,H*1.02,2,0),COLORFF0033;
DRAWTEXT(VAR31=232,H*1.06,'233天'),COLORYELLOW;
STICKLINE(VAR31=376,L*0.95,L*0.98,2,0),COLORFF9966;
DRAWTEXT(VAR31=376,L*0.95,'377天'),COLORYELLOW;


{压力一}
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
前期高位:REF(C,BARSLAST(HD)),COLOR00FF00,POINTDOT;
STICKLINE(C,前期高位,前期高位,8,0),COLORYELLOW;

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA30:MA(CLOSE,30);
MA60:MA(CLOSE,60);
红轨道:=MA(MA(CLOSE,3),1),LINETHICK1,COLORYELLOW;
绿轨道:=MA(MA(CLOSE,3),3);
上升:IF(红轨道>=绿轨道,绿轨道,DRAWNULL),COLORRED,LINETHICK2;
AA1:=3*SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1),3,1);
加仓:=IF(CROSS(AA1,REF(AA1+0.01,1)) AND LLV(AA1,2)=LLV(AA1,8) AND BETWEEN(AA1,20,60),1,0);
波段底:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) -
(2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
DRAWICON(加仓,L*0.97,7);
DRAWICON(CROSS(波段底,3),L*0.97,1);
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(X,13);
卖:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);
DRAWTEXT(FILTER(卖=1,1),HIGH*1.02,'卖'),COLORWHITE;
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(买=1,5),LOW-0.03,'买'),COLORRED;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
BDGD:=HHV(J,2)=HHV(J,8) AND J>80;
注意:=IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),1,0);
DRAWTEXT(注意 AND 卖!=1,HIGH*1.02,'减'),COLORLIBLUE;
加仓A:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
DRAWTEXT(FILTER((CROSS(加仓A,0) OR CROSS(CLOSE,CB)) AND 买!=1,3),LOW-0.03,'加'),COLOR0080FF;
MA18:=MA(C,18);
跟:=IF(MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18),1,0);
DRAWTEXT(MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18),LOW*0.96,'跟'),COLOR7F52AF;
买价:=((C-REF(MA5,1))/5+MA5)*1.004;
买条件:=CROSS(C,买价) AND 买价>REF(买价,1);
醉白K买进:IF(买条件,L,H),COLORWHITE,POINTDOT;
STICKLINE(买条件,H,L,0,1),COLORWHITE,LINETHICK2;
STICKLINE(买条件,O,C,4,1),COLORWHITE,LINETHICK2;
加码价:=((C-REF(MA10,1))/20+MA10)*1.004;
加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);
醉黄K加码:IF(加码条件,L,H),COLORYELLOW,POINTDOT;
STICKLINE(加码条件,H,L,0,1),COLORYELLOW,LINETHICK2;
STICKLINE(加码条件,O,C,4,1),COLORYELLOW,LINETHICK2;


HH0:=CONST(HHV(H,120))*1;
LL0:=CONST(LLV(L,120))*1;
MM0:=CONST((HH0+LL0)/2);
HH1:=IF(CONST(C)<MM0,LL0-(HH0-LL0)*0.4,LL0-(HH0-LL0)*0.4),COLORRED;
LL1:=LL0;HLMAX:=MAX(HH1,LL1);
HLMIN:=MIN(HH1,LL1);
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=(HLMAX-HLMIN);
HLMN3:=HHV(V,250)/2;
HLMN4:=HHV(V,250);
VZ:=(V-HLMN3)*HLMN2/HLMN4+HLMN1;
STICKLINE(C>=O,VZ,(0-HLMN3)*HLMN2/HLMN4+HLMN1,2.5,1),COLORRED;
STICKLINE(C<O,VZ,(0-HLMN3)*HLMN2/HLMN4+HLMN1,2.5,0),COLORCYAN;
(MA(V,5)-HLMN3)*HLMN2/HLMN4+HLMN1,COLORFFFFFF;
(MA(V,10)-HLMN3)*HLMN2/HLMN4+HLMN1,COLOR00FFFF;

T:=V=LLV(V,20);
DRAWICON(T,(V-HLMN3)*HLMN2/HLMN4+HLMN1,1);

STICKLINE(C/REF(C,1)>1.099,VZ,(0-HLMN3)*HLMN2/HLMN4+HLMN1,2,0),COLORRED;
STICKLINE(C/REF(C,1)<0.901,VZ,(0-HLMN3)*HLMN2/HLMN4+HLMN1,2,0),COLORGREEN;

VY:=(0-HLMN3)*HLMN2/HLMN4+HLMN1;

STICKLINE(V>=2*REF(V,1),VZ,VY,0.3,0),COLORWHITE;
STICKLINE(V>=3*REF(V,1),VZ,VY,0.3,0),COLORYELLOW;

MA13:=MA(C,3);
UU:=1,V<=LLV(V,13) AND MA13>REF(MA13,1);
TJ:=1,REF(V,1)<=LLV(V,13) AND MA13>REF(MA13,1),COLORRED,LINETHICK3;
DRAWTEXT(TJ=1,(V-HLMN3)*HLMN2/HLMN4+HLMN1+0.2,'买')COLORMAGENTA;


地:(0-HLMN3)*HLMN2/HLMN4+HLMN1-0.7,COLORBLACK;
天:CONST(HHV(C,120))*1+0.7,COLORBLACK;
BIAS11:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS12:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS13:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
短跌BIAS:IF(BIAS11<=-6,0.6+地,地),COLORBLACK,LINETHICK2;
中跌BIAS:IF(BIAS12<=-10,0.6+地,地),COLORBLUE,LINETHICK2;
长跌BIAS:IF(BIAS13<=-16,0.6+地,地),COLORRED,LINETHICK2;
短涨BIAS:IF(BIAS11>=6,天,天+0.6),COLORBLACK,LINETHICK2;
中涨BIAS:IF(BIAS12>=10,天,天+0.6),COLORBLUE,LINETHICK2;
长涨BIAS:IF(BIAS13>=16,天,天+0.6),COLORRED,LINETHICK2;


BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
DRAWTEXT(CROSS(BIAS,乖离) AND 乖离<-9,(V-HLMN3)*HLMN2/HLMN4+HLMN1+0.2,'底'),COLORRED;
Z:=MA(C,120);
VAR3:=(MA(C,5)-Z)/Z;
VAR4:=MA((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100,3);
DRAWTEXT(CLOSE>Z AND REF(VAR4,1)<30 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) ,0.99*LOW ,'★B'),COLORRED;
DRAWTEXT(REF(VAR4,1)<7 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) AND VAR3<-0.1,0.99*LOW ,'★B'),COLORGREEN;
DRAWTEXT(CROSS(VAR4,5) AND VAR3<-0.3,0.99*LOW ,'★B'),COLORBLUE;
DRAWTEXT(CROSS(95,VAR4) AND VAR3>0.3,1.01*HIGH ,'★S'),COLORRED;
DRAWTEXT( CROSS(93,VAR4) AND HHV(H,30)/LLV(L,30)>1.1 AND REF(Z,1)/Z>0.997 ,1.01*HIGH ,'★S'),COLORGREEN;
DRAWTEXT(CLOSE<Z AND Z<REF(Z,1) AND REF(VAR4,1)>90 AND VAR4<REF(VAR4,1) AND REF(VAR4,1)>REF(VAR4,2) ,1.01*HIGH,'★S'),COLORBLUE;
{量能平台}
N1:=30;
T1:=CONST(HHVBARS(V,N1));
T0:IF(CURRBARSCOUNT<=N1+7,CONST(IF(T1=0,C,REF(C,T1))),DRAWNULL),LINETHICK3;

回归主图改进文本格式 通达信主图指标 源码 贴图 无未来

回归主图改进文本格式 通达信主图指标 源码 贴图 无未来

回归主图改进文本格式 通达信主图指标 源码 贴图 无未来

推荐下载

赞助商广告