加入收藏
 

通达信指标 源码分享 宝塔线加上SAR

2018-08-06 10:12:02推荐星级:下载统计()
奇爱股票网提供通达信指标 源码分享 宝塔线加上SAR下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

通达信指标 源码分享 宝塔线加上SAR说明

VAR1:=SAR(10,2,20);
S:IF(VAR1>C,VAR1,DRAWNULL),COLORRED,CIRCLEDOT;
X:IF(VAR1<C,VAR1,DRAWNULL),COLORGREEN,CIRCLEDOT;
B1:=REF(C,1);B2:=REF(C,2);
SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));
SM:=IF(REF(SS,1)>0 OR REF(SS,1)<0,REF(SS,1),IF(REF(SS,2)>0 OR REF(SS,2)<0,REF(SS,2),IF(REF(SS,3)>0 OR REF(SS,3)<0,REF(SS,3),IF(REF(SS,4)>0 OR REF(SS,4)<0,REF(SS,4),IF(REF(SS,5)>0 OR REF(SS,5)<0,REF(SS,5),IF(REF(SS,6)>0 OR REF(SS,6)<0,REF(SS,6),IF(REF(SS,7)>0 OR REF(SS,7)<0,REF(SS,7),0)))))));
MC:IF(REF(SS,1)>0 OR REF(SS,1)<0,B2,IF(SM>0,MIN(B1,B2),MAX(B1,B2))),COLORFF00FF;
STICKLINE(SS=1 OR SM>=1 AND SS=0,B1,C,0.8,1),COLORRED;
STICKLINE(SS=-1 OR SM<=-1 AND SS=0,B1,C,0.8,0),COLORFF9000;
STICKLINE(SS=2,B2,C,0.8,1),COLORRED;
STICKLINE(SS=-2,B2,C,0.8,0),COLORFF9000;
STICKLINE((SS=-1 OR SS=-2) AND SM>0,B2,B1,0.8,1),COLORRED;
STICKLINE((SS=1 OR SS=2) AND SM<0,B2,B1,0.8,0),COLORFF9000;

推荐下载

赞助商广告