加入收藏
 

通达信指标 源码分享 定海神针

2018-07-25 10:16:27推荐星级:下载统计()
奇爱股票网提供通达信指标 源码分享 定海神针下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

通达信指标 源码分享 定海神针说明

{公式名称: 定海神针

公式描述:
无参数
公式类型: 技术指标公式-其他类型
画线方法: 副图
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
VAR1:=IF(1>=2442.459961*500,0,1);
VAR2:=IF(DATETODAY(DATE)<11700,1,DRAWNULL);
VAR3:=CLOSE/MA(CLOSE,40)*100<78;
VAR4:=CLOSE/MA(CLOSE,60)*100<74;
VAR5:=HIGH>LOW*1.051;
VAR6:=VAR5 AND COUNT(VAR5,5)>1;
VAR7:=IF(VAR6 AND (VAR3 OR VAR4),2,0);
VAR8:=CLOSE/REF(CLOSE,25)<=1.1;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,2),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,2)),7,1)*100<15;
VAR10:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
VAR11:=SMA(VAR10,2,1)*VAR2;
VAR12:=SMA(VAR11,2,1)*VAR2;
VAR13:=IF(VAR11>REF(VAR11,1) AND REF(VAR11,1)<REF(VAR11,2) AND VAR11<23,1.5,0);
VAR14:=LLV(LOW,4)=LLV(LOW,120);
VAR15:=(CLOSE-MA(CLOSE,58))/MA(CLOSE,58)<(-0.07)*VAR2;
VAR16:=(INDEXC-HHV(INDEXC,8))/HHV(INDEXC,8)<(-0.05) AND MA(INDEXA,125)/MA(INDEXV,125)/(MA(INDEXA,5)/MA(INDEXV,5))>1.12;
VAR17:=BARSLAST(VAR16)<10;
VAR18:=MA(CLOSE,27);
VAR19:=(CLOSE-VAR18)/VAR18*100;
VAR20:=MA(VAR19,2)*VAR1;
VAR21:=BARSLAST(CROSS((-10),VAR20)=1)*VAR2;
VAR22:=VAR20<(-10) AND VAR21>3;
VAR23:=ABS(IF(VAR22,VAR20,0))*VAR2;
VAR24:=VAR23>0;
VAR25:=MA(CLOSE,80)-MA(CLOSE,13)/3;
VAR26:=MA((CLOSE-VAR25)/VAR25,1)*VAR2;
VAR27:=EMA(VAR26,12)*0.5;
VAR28:=EMA(VAR26,3)*VAR1;
VAR29:=ABS(IF(LLV(VAR28-VAR27,12)>0,0,1));
VAR30:=CLOSE/(EMA(EMA((CLOSE+LOW+HIGH)/3,3),26)*0.9)<0.95;
VAR31:=MA((CLOSE-MA(CLOSE,21))/MA(CLOSE,21),3)*100;
VAR32:=VAR31<(-15)*VAR2;
VAR33:=(CLOSE-MA(CLOSE,28))/MA(CLOSE,28)*100<(-23)*VAR2;
VAR34:=VAR8 AND VAR7 AND VAR9 AND VAR13;
VAR35:=VAR32>0 AND VAR30>0 AND VAR29>0 AND VAR24>0 AND VAR15>0 AND VAR17>0 AND VAR33>0 AND CLOSE>REF(CLOSE,1);
VAR36:=VAR35*VAR2 AND VAR34*VAR2;
VAR37:=(CLOSE/MA(CLOSE,40)*100<78)*VAR1;
VAR38:=(CLOSE/MA(CLOSE,60)*100<74)*VAR1;
VAR39:=HIGH>LOW*1.051;
VAR40:=VAR39 AND COUNT(VAR39,5)>1;
VAR41:=IF(VAR40 AND (VAR37 OR VAR38),2,0);
VAR42:=CLOSE/REF(CLOSE,25)<=1.1;
VAR43:=SMA(MAX(CLOSE-REF(CLOSE,2),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,2)),7,1)*100<15;
VAR44:=SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,2,1)*VAR2;
VAR45:=SMA(VAR44,2,1)*VAR2;
VAR46:=VAR44>REF(VAR44,1) AND REF(VAR44,1)<REF(VAR44,2) AND VAR44<23;
VAR47:=VAR41 AND VAR42 AND VAR43 AND VAR46;
VAR48:=3*SMA((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100,5,1)-2*SMA((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)*VAR1)*100,5,1)*VAR2;
VAR49:=EMA(VAR48,5)*VAR2;
VAR50:=(VAR49-REF(VAR49,1))/REF(VAR49,1)*100+10;
VAR51:=EMA(CLOSE,5);
VAR52:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)*VAR1-LLV(LOW,20))*100;
VAR53:=SMA(VAR52,6,1)*VAR2;
VAR54:=IF(LLV(VAR53,5)<10 AND (CLOSE=LLV(CLOSE,10) OR LOW=LLV(LOW,10)) AND CLOSE>REF(CLOSE,1)*0.905,40,0)*VAR2;
VAR55:=IF(VAR50<(-3) OR LLV(VAR53,5)*VAR1<10 AND (CLOSE=LLV(CLOSE,10) OR LOW=LLV(LOW,10)) AND CLOSE>REF(CLOSE,1)*0.905,1,0)*VAR2;
神针:VAR36 AND VAR47 AND VAR55,COLORRED;
STICKLINE(IF(神针,(-120),0),30,0,7,0),COLOR000044;
STICKLINE(IF(神针,(-120),0),30,0,6,0),COLOR000033;
STICKLINE(IF(神针,(-120),0),30,0,5,0),COLOR000055;
STICKLINE(IF(神针,(-120),0),30,0,4,0),COLOR000077;
STICKLINE(IF(神针,(-120),0),30,0,3,0),COLOR000099;
STICKLINE(IF(神针,(-120),0),30,0,2,0),COLORLIMAGENTA;

推荐下载

赞助商广告