加入收藏
 

通达信指标 源码分享 撑压系统

2018-07-24 09:17:47推荐星级:下载统计()
奇爱股票网提供通达信指标 源码分享 撑压系统下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

通达信指标 源码分享 撑压系统说明

XA_1:=EMA(CLOSE,2);
XA_2:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
STICKLINE(XA_1>=XA_2,REFDATE(HHV(HIGH,0),DATE),REFDATE(LLV(LOW,0),DATE),6,0),COLOR000030;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
XA_3:=STRCAT(HYBLOCK,6);
XA_4:=STRCAT(XA_3,DYBLOCK);
XA_5:=STRCAT(XA_4,6);
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(XA_5,GNBLOCK)),COLORRED;
NOTEXTMA1:MA(CLOSE,M1),COLORWHITE;
NOTEXTMA2:MA(CLOSE,M2),COLORMAGENTA;
NOTEXTMA3:MA(CLOSE,M3),COLORCYAN;
NOTEXTMA4:MA(CLOSE,M4),COLORGREEN;
XA_6:=REF(CLOSE,1);
XA_7:=REF(HIGH,8)=HHV(HIGH,2*8+1);
XA_8:=REF(LOW,8)=LLV(LOW,2*8+1);
XA_9:=BACKSET(XA_7,8+1);
XA_10:=BACKSET(XA_8,8+1);
XA_11:=FILTER(XA_9,8) AND HIGH=HHV(HIGH,8+1);
XA_12:=FILTER(XA_10,8) AND LOW=LLV(LOW,8+1);
XA_13:=BARSLAST(XA_11);
XA_14:=BARSLAST(XA_12);
XA_15:=IF(XA_11,CURRBARSCOUNT,0);
XA_16:=IF(XA_12,CURRBARSCOUNT,0);
XA_17:=IF(XA_13,REF(XA_15,XA_13),XA_15);
XA_18:=IF(XA_14,REF(XA_16,XA_14),XA_16);
XA_19:=CONST(XA_17);
XA_20:=CONST(XA_18);
XA_21:=CONST(REF(HIGH,XA_19-1));
XA_22:=CONST(REF(LOW,XA_20-1));
XA_23:=REF(XA_17,XA_13+1);
XA_24:=REF(XA_18,XA_14+1);
XA_25:=CONST(XA_23);
XA_26:=CONST(XA_24);
XA_27:=CONST(REF(HIGH,XA_23-1));
XA_28:=CONST(REF(LOW,XA_24-1));
XA_29:=BACKSET(ISLASTBAR,XA_19);
XA_30:=BACKSET(ISLASTBAR,XA_20);
XA_31:=BACKSET(ISLASTBAR,XA_23);
XA_32:=BACKSET(ISLASTBAR,XA_24);
XA_33:=INTPART(3*8/5);
XA_34:=REF(HIGH,XA_33)=HHV(HIGH,2*XA_33+1);
XA_35:=BACKSET(XA_34,XA_33+1);
XA_36:=FILTER(XA_35,XA_33) AND HIGH=HHV(HIGH,XA_33+1);
XA_37:=BARSLAST(XA_36);
XA_38:=IF(XA_36,CURRBARSCOUNT,0);
XA_39:=IF(XA_37,REF(XA_38,XA_37),XA_38);
XA_40:=CONST(XA_39);
XA_41:=REF(XA_39,XA_37+1);
XA_42:=CONST(XA_41);
XA_43:=REF(LOW,XA_33)=LLV(LOW,2*XA_33+1);
XA_44:=BACKSET(XA_43,XA_33+1);
XA_45:=FILTER(XA_44,XA_33) AND LOW=LLV(LOW,XA_33+1);
XA_46:=BARSLAST(XA_45);
XA_47:=IF(XA_45,CURRBARSCOUNT,0);
XA_48:=IF(XA_46,REF(XA_47,XA_46),XA_47);
XA_49:=CONST(XA_48);
XA_50:=REF(XA_48,XA_46+1);
XA_51:=CONST(XA_50);
XA_52:=REF(HIGH,5)=HHV(HIGH,2*5+1);
XA_53:=FILTER(XA_52,5);
XA_54:=BACKSET(XA_53,5+1);
XA_55:=FILTER(XA_54,5);
XA_56:=BACKSET(ISLASTBAR,BARSLAST(XA_55)+1);
XA_57:=XA_56>REF(XA_56,1);
XA_58:=REF(LOW,5)=LLV(LOW,2*5+1);
XA_59:=FILTER(XA_58,5);
XA_60:=BACKSET(XA_59,5+1);
XA_61:=FILTER(XA_60,5);
XA_62:=BACKSET(ISLASTBAR,BARSLAST(XA_61)+1);
XA_63:=XA_62>REF(XA_62,1);
XA_64:=10;
XA_65:=10;
XA_66:=REF(HIGH,XA_64)=HHV(HIGH,2*XA_64+1);
XA_67:=BACKSET(XA_66,XA_64+1);
XA_68:=FILTER(XA_67,XA_64) AND HIGH=HHV(HIGH,XA_64+1);
XA_69:=BARSLAST(XA_68);
XA_70:=IF(XA_68,CURRBARSCOUNT,0);
XA_71:=IF(XA_69,REF(XA_70,XA_69),XA_70);
XA_72:=CONST(XA_71);
XA_73:=REF(XA_71,XA_69+1);
XA_74:=CONST(XA_73);
XA_75:=REF(LOW,XA_65)=LLV(LOW,2*XA_65+1);
XA_76:=BACKSET(XA_75,XA_65+1);
XA_77:=FILTER(XA_76,XA_65) AND LOW=LLV(LOW,XA_65+1);
XA_78:=BARSLAST(XA_77);
XA_79:=IF(XA_77,CURRBARSCOUNT,0);
XA_80:=IF(XA_78,REF(XA_79,XA_78),XA_79);
XA_81:=CONST(XA_80);
XA_82:=REF(XA_80,XA_78+1);
XA_83:=CONST(XA_82);
XA_84:=BACKSET(ISLASTBAR,SUMBARS(VOL,CAPITAL));
XA_85:=XA_84>REF(XA_84,1);
NOTEXT1上:DRAWLINE(CURRBARSCOUNT=XA_42,HIGH,CURRBARSCOUNT=XA_40,HIGH,1),COLORGRAY;
NOTEXT1下:DRAWLINE(CURRBARSCOUNT=XA_51,LOW,CURRBARSCOUNT=XA_49,LOW,1),COLORGRAY;
NOTEXT1:IF(XA_31,XA_27,DRAWNULL),POINTDOT,COLORLIGRAY;
NOTEXT2:IF(XA_29,XA_21,DRAWNULL),POINTDOT,COLORLIGRAY;
NOTEXT3:IF(XA_32,XA_28,DRAWNULL),POINTDOT,COLORLIGRAY;
NOTEXT4:IF(XA_30,XA_22,DRAWNULL),POINTDOT,COLORLIGRAY;
高压:DRAWLINE(CURRBARSCOUNT=XA_74,HIGH,CURRBARSCOUNT=XA_72,HIGH,1),COLORMAGENTA;
低撑:DRAWLINE(CURRBARSCOUNT=XA_83,LOW,CURRBARSCOUNT=XA_81,LOW,1),COLORMAGENTA;
短压:DRAWLINE(XA_55,HIGH,XA_57,HIGH,1),COLORYELLOW;
短撑:DRAWLINE(XA_61,LOW,XA_63,LOW,1),COLORYELLOW;
XA_86:=MA(MA(CLOSE,3),1);
轨道:MA(MA(CLOSE,3),3),COLOR32CD32,LINETHICK2;
NOTEXT_升:IF(XA_86>=轨道,轨道,DRAWNULL),COLORMAGENTA,LINETHICK2;
涨家数:INDEXADV,NODRAW,COLORRED;
跌家数:INDEXDEC,NODRAW,COLORCYAN;
流通市值:FINANCE(40)/100000000,NODRAW,COLORRED;
流通亿股:FINANCE(7)/100000000,NODRAW,COLOR0080FF;
日成交亿:AMOUNT/100000000,NODRAW,COLORMAGENTA;
净买额:(DYNAINFO(23)-DYNAINFO(22))*CLOSE/1000000,NODRAW,COLORRED;
买卖比:DYNAINFO(23)/DYNAINFO(22),NODRAW,COLORWHITE;
XA_87:=IF(PERIOD=16,0.03,IF(PERIOD=15,0.03,IF(PERIOD=14,0.006,IF(PERIOD=11,0.02,IF(PERIOD=10,0.02,IF(PERIOD=9,0.02,IF(PERIOD=8,0.002,IF(PERIOD=7,0.05,IF(PERIOD=6,0.03,IF(PERIOD=5,0.018,IF(PERIOD=4,0.005,IF(PERIOD=3,0.004,IF(PERIOD=2,0.003,IF(PERIOD=1,0.0015,IF(PERIOD=0,0.0012,0)))))))))))))));
XA_88:=MA(CLOSE,5);
XA_89:=MA(CLOSE,10);
XA_90:=REF(HIGH,5)=HHV(HIGH,11);
XA_91:=REF(LOW,5)=LLV(LOW,11);
XA_92:=BACKSET(XA_90,6)>BACKSET(XA_90,5);
XA_93:=BACKSET(XA_91,6)>BACKSET(XA_91,5);
XA_94:=IF(BARSLAST(XA_92)=BARSLAST(XA_93) AND XA_88>XA_89,XA_92,IF(BARSLAST(XA_93)>BARSLAST(XA_92),XA_92,0));
XA_95:=IF(BARSLAST(XA_92)=BARSLAST(XA_93) AND XA_89>XA_88,XA_93,IF(BARSLAST(XA_92)>BARSLAST(XA_93),XA_93,0));
XA_96:=XA_94 AND HIGH=HHV(HIGH,BARSLAST(XA_95));
XA_97:=XA_95 AND LOW=LLV(LOW,BARSLAST(XA_94));
XA_98:=IF(XA_96,HIGH,DRAWNULL);
XA_99:=IF(XA_97,LOW,DRAWNULL);
XA_100:=LOW>REF(HIGH,1) AND DAY!=REF(DAY,1);
XA_101:=HIGH<REF(LOW,1) AND DAY!=REF(DAY,1);
XA_102:=REF(LOW,BARSLAST(XA_100));
XA_103:=REF(HIGH,BARSLAST(XA_101));
XA_104:=REF(HIGH,BARSLAST(XA_96));
XA_105:=REF(LOW,BARSLAST(XA_96));
XA_106:=REF(HIGH,BARSLAST(XA_96)+1);
XA_107:=REF(LOW,BARSLAST(XA_96)+1);
XA_108:=REF(HIGH,BARSLAST(XA_96)+2);
XA_109:=REF(LOW,BARSLAST(XA_96)+2);
XA_110:=REF(HIGH,BARSLAST(XA_97));
XA_111:=REF(LOW,BARSLAST(XA_97));
XA_112:=REF(HIGH,BARSLAST(XA_97)+1);
XA_113:=REF(LOW,BARSLAST(XA_97)+1);
XA_114:=REF(HIGH,BARSLAST(XA_97)+2);
XA_115:=REF(LOW,BARSLAST(XA_97)+2);
XA_116:=IF(XA_105<=XA_107,XA_108,XA_106);
XA_117:=IF(XA_106<XA_105,XA_105,IF(XA_105<=XA_107,XA_109,XA_107));
XA_118:=IF(XA_113>XA_110,XA_110,IF(XA_110>=XA_112,XA_114,XA_112));
XA_119:=IF(XA_110>=XA_112,XA_115,XA_113);
XA_120:=XA_104>XA_118 AND XA_96;
XA_121:=XA_111<XA_117 AND XA_97;
XA_122:=XA_120 AND XA_104>XA_110 AND XA_105>XA_111 AND XA_107>XA_111;
XA_123:=XA_121 AND XA_111<XA_105 AND XA_110<XA_104 AND XA_112<XA_104;
XA_124:=HIGH<=REF(HIGH,1) AND LOW>=REF(LOW,1) OR (HIGH>=REF(HIGH,1) AND LOW<=REF(LOW,1));
XA_125:=COUNT(XA_124,BARSLAST(XA_97));
XA_126:=COUNT(XA_124,BARSLAST(XA_96));
XA_127:=COUNT(XA_100,BARSLAST(XA_97));
XA_128:=COUNT(XA_101,BARSLAST(XA_96));
XA_129:=IF(XA_125>0,XA_125+2+笔,IF(XA_126,XA_126+2+笔,3));
XA_130:=IF(XA_127,XA_129-XA_127,IF(XA_128,XA_129-XA_128,XA_129));
XA_131:=XA_122 AND BARSLAST(XA_123)>XA_130;
XA_132:=XA_123 AND BARSLAST(XA_122)>XA_130;
XA_133:=XA_96 AND REF(HIGH,BARSLAST(XA_96))>=REF(HIGH,BARSLAST(XA_131)) AND BARSLAST(XA_132)>BARSLAST(XA_131) OR (XA_120 AND COUNT(XA_100,BARSLAST(XA_121))>0 AND REF(HIGH,BARSLAST(XA_120))>REF(HIGH,BARSLAST(XA_131)));
XA_134:=XA_97 AND REF(LOW,BARSLAST(XA_97))<=REF(LOW,BARSLAST(XA_132)) AND BARSLAST(XA_131)>BARSLAST(XA_132) OR (XA_121 AND COUNT(XA_101,BARSLAST(XA_120))>0 AND REF(LOW,BARSLAST(XA_121))<REF(HIGH,BARSLAST(XA_132)));
XA_135:=IF(BARSLAST(XA_134)>BARSLAST(XA_133),REF(HIGH,BARSLAST(XA_133)),REF(HIGH,BARSLAST(XA_134)));
XA_136:=IF(BARSLAST(XA_133)>BARSLAST(XA_134),REF(LOW,BARSLAST(XA_134)),REF(LOW,BARSLAST(XA_133)));
XA_137:=XA_133 AND HIGH=HHV(XA_135,BARSLAST(XA_134)+1) AND HIGH>REF(HIGH,1) AND BARSLAST(XA_134)>BARSLAST(XA_133);
XA_138:=XA_55 AND LOW=LLV(XA_136,BARSLAST(XA_133)+1) AND LOW<REF(LOW,1) AND BARSLAST(XA_133)>BARSLAST(XA_134);
XA_139:=XA_137 OR (XA_96 AND REF(HIGH,BARSLAST(XA_96))>REF(HIGH,BARSLAST(XA_137)) AND BARSLAST(XA_138)>BARSLAST(XA_137));
XA_140:=XA_138 OR (XA_97 AND REF(LOW,BARSLAST(XA_97))<REF(LOW,BARSLAST(XA_138)) AND BARSLAST(XA_137)>BARSLAST(XA_138));
NOTEXT高点:IF(XA_131,HIGH,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK4;
NOTEXT低点:IF(XA_132,LOW,DRAWNULL),POINTDOT,COLORYELLOW,LINETHICK4;
NOTEXT上:DRAWLINE(XA_132,LOW,XA_131,HIGH,0),COLORGRAY;
NOTEXT下:DRAWLINE(XA_131,HIGH,XA_132,LOW,0),COLOR888888;
XA_141:=BARSLAST(XA_131);
XA_142:=BARSLAST(XA_132);
DRAWNUMBER(XA_132,LOW,XA_141),COLORYELLOW;
DRAWNUMBER(XA_131,HIGH+HIGH*XA_87,XA_142),COLORGREEN;
DRAWNUMBER(ISLASTBAR,IF(BARSLAST(XA_131)>BARSLAST(XA_132),LOW,HIGH+HIGH*XA_87),MIN(XA_141,XA_142)),COLORMAGENTA;

推荐下载

赞助商广告