加入收藏
 

通达信指标 源码分享 支撑阻力

2018-07-18 09:20:11推荐星级:下载统计()
奇爱股票网提供通达信指标 源码分享 支撑阻力下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

通达信指标 源码分享 支撑阻力说明

DRAWGBK(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0);
顶部:=XMA(HHV(H,20),13);
底部:=XMA(LLV(L,20),13);
DRAWBAND(顶部,RGB(25,25,25),底部,RGB(25,25,25));
MMM:=MA(C,21);
DRAWTEXT((CLOSE<MMM),MMM,'*'),COLOR00FF00,LINETHICK7;
DRAWTEXT((CLOSE>MMM),MMM,'*'),COLOR0000FF,LINETHICK7;
STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000046;
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;

VAR2:=LLV(LOW,34);
VAR3:=HHV(HIGH,34);
SK:=EMA((VAR1-VAR2)/(VAR3-VAR2)*100,13);
SD:=EMA(SK,3);
DRAWKLINE(H,O,L,C);

TYP:=(HIGH+LOW+CLOSE)/3;
多头力度:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))COLORRED;
TYP1:=(HIGH-LOW-CLOSE)/3;
空头力度:=(TYP1-MA(TYP1,14))/(0.015*AVEDEV(TYP1,14))COLORGREEN;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
多头努力:=多头力度>REF(多头力度,1) AND 空头力度<REF(空头力度,1);
空头努力:=空头力度>REF(空头力度,1) AND 多头力度<REF(多头力度,1);
多空低迷:=空头力度<REF(空头力度,1) AND 多头力度<REF(多头力度,1);
多空争夺:=空头力度>REF(空头力度,1) AND 多头力度>REF(多头力度,1);
DRAWTEXT_FIX(ISLASTBAR AND 多头努力,0.11,0.01,0,'多头努力'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND 多头努力 AND 多头力度>空头力度,0.11,0.05,0,'短期看多'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND 多空低迷 AND 多头力度>空头力度,0.11,0.05,0,'注意支撑'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND 空头努力 AND 多头力度<空头力度,0.11,0.05,0,'短期看空'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND 空头努力,0.15,0.01,0,'空头努力'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND 多空低迷,0.13,0.01,0,'多空低迷'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND 多空争夺,0.13,0.01,0,'多空争夺'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND SK>SD AND SK>REF(SK,1),0.13,0.08,0,'中期处于多方战场'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND SK<SD AND SK<REF(SK,1),0.13,0.08,0,'中期处于空方战场'),COLORYELLOW;
明日阻力:=2*E-LOW,NODRAW;
明日支撑:=2*E-HIGH;
明日突破:=E+(HIGH-LOW);
明日反转:=E-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
DRAWTEXT_FIX(ISLASTBAR,0.01,0.01,0,'明日阻力'),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.01,0,明日阻力),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.05,0,'明日支撑'),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.05,0,明日支撑),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.09,0,'明日突破'),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.09,0,明日突破),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.13,0,'明日反转'),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.13,0,明日反转),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.17,0,'今日阻力'),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.17,0,今日阻力),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.01,0.21,0,'今日支撑'),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.21,0,今日支撑),COLOR0080FF;

趋势线:=MA(C,21),NODRAW,COLORRED;
O1:=(SUM(EMA((CLOSE+LOW)/2,1)/3,3)),COLOR00FFFF,LINETHICK1;
O2:=EMA(O1,3),COLORFF00FF,LINETHICK1;
O3:=EMA(O2,3),COLOR00FF00,LINETHICK1;

MA5:MA(C,5)COLORWHITE;
MA13:MA(C,13)COLORYELLOW;
MA21:MA(C,21)COLORMAGENTA;
MA55:MA(C,55)COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR AND C>MA21 AND MA5>MA13 AND MA13>MA21 AND MA21>MA55 AND SK<80,0.13,0.13,0,'中期持股'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND C<MA13 AND MA5<MA13 AND MA13<MA21 AND MA21<MA55 AND SK<80,0.13,0.13,0,'今日 减仓 持币 观望'),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR AND C>5 AND SK<30 AND SK>REF(SK,1),0.15,0.16,0,'中期布局区域'),COLORYELLOW;
VLA:=HHV(V,60);
VLB:=HHV(V,90);
DRAWICON(V>=VLA && V<VLB AND CROSS(多头力度,100),L*0.98,38);
DRAWTEXT(V>=VLA && V<VLB,L*0.98,'60量');
DRAWICON(V>=VLB AND CROSS(多头力度,100),L*0.98,38);
DRAWTEXT(V>=VLB ,L*0.98,'90量');
O4:=EMA(C,4);
O5:=EMA(SLOPE(C,20)*10+C,35);
DRAWICON(V>=VLA AND CROSS(O4,O5) AND C>O,LOW*0.98,1);
DRAWTEXT_FIX(ISLASTBAR AND V>=VLA AND V<VLB,0.5,5,0,'今日爆巨量,如果收长上影线要小心!收阴线要逃跑!'),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR AND V>=VLB,0.5,0.01,0,'爆巨量必须收盘价是最高价,最好没有长上影上影线!收阴线要逃跑!'),COLORCYAN;

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,' ');
DRAWTEXT_FIX(ISLASTBAR,0,5,0,STRCAT(Z4,GNBLOCK)),COLORYELLOW;
时1:=PEAKBARS(1,13,1) AND L=LLV(L,13);
时2:=TROUGHBARS(2,13,1);
XG:=MAX(时1,时2);

XGL:=XG<=1 AND V>=VLA && V<VLB AND CROSS(多头力度,100);
DRAWICON(XGL,LOW*0.98,11);


DRAWICON(REF(L<=底部,1) AND C>O AND CROSS(C,底部),L-0.29,17);

VOLUME:=VOL;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,60);
A22:=HHV(VOLUME,60);
A55:=COUNT(V<MAVOL2,5)>=3;
XG1:=CROSS(VOL,MAVOL1) AND CROSS(C,MA(C,20));
STICKLINE(XG1,H,L,0,0),COLORFF00FF;
STICKLINE(XG1,C,O,3,0),COLOR990099;
STICKLINE(XG1,C,O,2,0),COLORBB00BB;
STICKLINE(XG1,C,O,1,0),COLORDD00DD;
STICKLINE(XG1,C,O,0.3,0),COLORFF00FF;
DRAWTEXT(XG1,H*0.98,'↖量价动');
X1:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>50;
XYX1:=CROSS(MA5,MA13) AND X1 AND V<VLA;
DRAWTEXT(XYX1,L*0.98,'↖有型');
AA:=XYX1;
STICKLINE(AA,H,L,0,1),COLORYELLOW;
STICKLINE(AA,C,O,3.2,0),COLOR117777;
STICKLINE(AA,C,O,2.6,0),COLOR119999;
STICKLINE(AA,C,O,1.9,0),COLOR11BBBB;
STICKLINE(AA,C,O,1.1,0),COLOR11DDDD;
STICKLINE(AA,C,O,0.3,0),COLOR44FFFF;
DRAWTEXT_FIX(ISLASTBAR AND XYX1,0.01,0.89,0,'暴跌后的第一个有型考虑为卖点!'),COLORLIMAGENTA;
DRAWTEXT_FIX(ISLASTBAR AND XYX1,0.01,0.93,0,'盘整后的有型可以考虑建底仓!'),COLORLIMAGENTA;

Y1:=H-O;
Y2:=O-L;
Y3:=Y2>Y1;
X11:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>45;
X22:=H<MA55;
DRAWICON(X11 AND Y3 AND C>O,L*0.98,29);

推荐下载

赞助商广告