加入收藏
 

通达信指标 源码分享 小城飞天

2018-06-13 10:28:36推荐星级:下载统计()
奇爱股票网提供通达信指标 源码分享 小城飞天下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

通达信指标 源码分享 小城飞天说明

HJ_1:=EMA(CLOSE,13);
牛线:EXPMA(CLOSE,2),COLOR0578FF;
HJ_2:=EMA(CLOSE,3);
MA8:EMA(HJ_2,8),COLORMAGENTA;
飞天:HHV(MA(HIGH,6),10),COLORWHITE;
MA34:MA(CLOSE,34),NODRAW;
HJ_3:=MA(CLOSE,144);
HJ_4:=VOL*(OPEN+CLOSE)/2;
博杀生命线:SUM(HJ_4,88)/SUM(VOL,88),COLORYELLOW,LINETHICK2;
HJ_5:=(HIGH+LOW+CLOSE)/3;
HJ_6:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
HJ_7:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-HJ_5);
HJ_8:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
HJ_9:=IF(HIGH=LOW,1,HJ_5-MIN(CLOSE,OPEN));
HJ_10:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
HJ_11:=HJ_6*HJ_10;
HJ_12:=HJ_7*HJ_10;
HJ_13:=HJ_8*HJ_10;
HJ_14:=HJ_9*HJ_10;
HJ_15:=HJ_14+HJ_13;
HJ_16:=HJ_11+HJ_12;
HJ_17:=HJ_15-HJ_16;
HJ_18:=HJ_17;
HJ_19:=MA(HJ_17,5)*20;
HJ_20:=5;
HJ_21:=13;
HJ_22:=SUM(HJ_18,HJ_20)*3;
HJ_23:=IF(HJ_22>REF(HJ_22,1),HJ_22,DRAWNULL);
HJ_24:=SMA(HJ_19,3,1);
HJ_25:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
HJ_26:=POW(SMA(HJ_25,2,1),5)/POW(10,8);
HJ_27:=POW(SMA(HJ_25,2,1),5)/POW(10,10);
HJ_28:=(HJ_26+HJ_27)/2;
HJ_29:=IF(CROSS(HJ_28,1),1,0) AND HJ_24>REF(HJ_24,1);
HJ_30:=SMA(HJ_19,3,1);
HJ_31:=SMA(HJ_30,3,1);
HJ_32:=(5*HJ_31+4*REF(HJ_31,1)+3*REF(HJ_31,2)+2*REF(HJ_31,3)+REF(HJ_31,4))/15;
HJ_33:=HJ_18>0 AND MA(VOL,5)>MA(MA(VOL,5),5) AND CROSS(HJ_30,HJ_31);
HJ_34:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1),3,1);
HJ_35:=EMA(HJ_34,3);
HJ_36:=EMA(CLOSE,5);
HJ_37:=EMA(CLOSE,10);
HJ_38:=EMA(CLOSE,20);
HJ_39:=EMA(CLOSE,55);
HJ_40:=(3*CLOSE+LOW+OPEN+HIGH)/6;
HJ_41:=(20*HJ_40+19*REF(HJ_40,1)+18*REF(HJ_40,2)+17*REF(HJ_40,3)+16*REF(HJ_40,4)+15*REF(HJ_40,5)+14*REF(HJ_40,6)+13*REF(HJ_40,7)+12*REF(HJ_40,8)+11*REF(HJ_40,9)+10*REF(HJ_40,10)+9*REF(HJ_40,11)+8*REF(HJ_40,12)+7*REF(HJ_40,13)+6*REF(HJ_40,14)+5*REF(HJ_40,15)+4*REF(HJ_40,16)+3*REF(HJ_40,17)+2*REF(HJ_40,18)+REF(HJ_40,20))/210;
HJ_42:=HJ_41<REF(HJ_41,1) AND REF(HJ_41,1)>REF(HJ_41,2);
DRAWICON(HJ_42 AND HJ_41>MA8,LOW,2);
HJ_43:=EMA(CLOSE,26);
CG:HJ_43,COLORRED,LINETHICK2;
HJ_44:=HJ_43+2*STD(CLOSE,26);
HJ_45:=HJ_43-2*STD(CLOSE,26);
HJ_46:=REF(CLOSE,1);
HJ_47:=SMA(MAX(CLOSE-HJ_46,0),3,1)/SMA(ABS(CLOSE-HJ_46),3,1)*100;
STICKLINE(CROSS(88,HJ_47) AND 牛线<REF(牛线,1),HIGH,HIGH+0.07,3,0),COLORFFFF11;
HJ_48:=(CLOSE+LOW+HIGH)/3;
HJ_49:=ATAN(EMA(HJ_48,13)-REF(EMA(HJ_48,13),1))*3.1416*10;
HJ_50:=EMA(CLOSE,8);
DRAWTEXT(FILTER(HJ_49>1 AND EMA(HJ_48,13)>REF(EMA(HJ_48,8),1),10),HJ_50,1),COLORWHITE;
HJ_51:=(CLOSE/REF(CLOSE,1)-1)*100;
HJ_52:=(CLOSE/OPEN-1)*100;
HJ_53:=MAX(HJ_51,HJ_52);
HJ_54:=HHV(HJ_53,3);
HJ_55:=HHV(HJ_53,4);
HJ_56:=HHV(HJ_53,5);
HJ_57:=HHV(HJ_53,6);
HJ_58:=HHV(HJ_53,7);
HJ_59:=HHV(HJ_53,9);
HJ_60:=REF((HJ_54+HJ_55+HJ_56+HJ_57+HJ_58+HJ_59)/6,1);
HJ_61:=FILTER(HJ_53>HJ_60,8) OR FILTER(HJ_53>HJ_60,5);
STICKLINE(HJ_61,OPEN,CLOSE,3.5,0),COLORC8C8C8;
STICKLINE(HJ_61,OPEN,CLOSE,3.5,0),COLORDBDBDB;
STICKLINE(HJ_61,OPEN,CLOSE,3,5),COLOREAEAEA;
STICKLINE(HJ_61,OPEN,CLOSE,3,5),COLORF6F6F6;
HJ_62:=(MA(LOW,6)+MA(LOW,13)+MA(LOW,26))/3;
HJ_63:=IF(LOW=LLV(LOW,5),LOW=LLV(LOW,5),CLOSE=LLV(CLOSE,5));
HJ_64:=REF(HJ_63,1) OR REF(HJ_63,2);
HJ_65:=IF(CLOSE>=OPEN,OPEN,CLOSE);
HJ_66:=ABS(CLOSE-OPEN)/3;
HJ_67:=HJ_64 AND REF(CLOSE,1)<REF(MA(CLOSE,3),1) AND CLOSE>MA(CLOSE,3) AND CLOSE>=HJ_62;
STICKLINE(HJ_67,HJ_65,HJ_65+HJ_66,3.5,0),COLORRED;
HJ_68:=EMA(CLOSE,12)-EMA(CLOSE,26);
HJ_69:=EMA(HJ_68,9);
HJ_70:=2*(HJ_68-HJ_69);
HJ_71:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2);
HJ_72:=EMA(HJ_71,9/2);
HJ_73:=CROSS(HJ_68,HJ_69) AND CROSS(HJ_71,HJ_72);
HJ_74:=CROSS(HJ_68,HJ_69) OR CROSS(HJ_71,HJ_72);
DRAWTEXT(HJ_73,HIGH+0.0015,2),COLORRED;
HJ_75:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HJ_76:=HIGH-REF(HIGH,1);
HJ_77:=REF(LOW,1)-LOW;
HJ_78:=EXPMEMA(IF(HJ_76>0 AND HJ_76>HJ_77,HJ_76,0),14);
HJ_79:=EXPMEMA(IF(HJ_77>0 AND HJ_77>HJ_76,HJ_77,0),14);
HJ_80:=HJ_78*100/HJ_75;
HJ_81:=HJ_79*100/HJ_75;
HJ_82:=HHV(HIGH,3);
HJ_83:=LLV(LOW,3);
HJ_84:=BARSLAST(HJ_82>REF(HJ_82,1));
HJ_85:=BARSLAST(HJ_83<REF(HJ_83,1));
HJ_86:=CROSS(HJ_85,HJ_84) AND CROSS(CLOSE,HJ_36) AND CROSS(CLOSE,HJ_37) AND HJ_37>HJ_38 AND HJ_38>REF(HJ_38,1);
HJ_87:=CROSS(HJ_85,HJ_84) AND HJ_61;
HJ_88:=OPEN<HJ_36 AND OPEN<HJ_38 AND CLOSE>HJ_36 AND CLOSE>=HJ_38 AND HJ_36>HJ_35;
DRAWICON(HJ_88 OR HJ_87 OR HJ_86 AND LOW<MA8,LOW*0.995,25);
HJ_89:=MA8>REF(MA8,1) AND HJ_37>REF(HJ_37,1) AND HJ_38>REF(HJ_38,1) AND HJ_36>HJ_38 AND CLOSE>HJ_36 AND OPEN<HJ_36 AND OPEN<HJ_37 AND (HJ_68>REF(HJ_68,1) AND HJ_69>REF(HJ_69,1) OR (HJ_68>0 AND HJ_69>0)) AND HJ_37>HJ_43;
DRAWICON(HJ_89,HIGH+0.01,23);
NOTEXT弱:IF(CG<MA(CG,2),CG,DRAWNULL),COLORGREEN,LINETHICK2;
压力:DRAWLINE(HIGH>=HHV(HIGH,3),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,1),1),DOTLINE,COLORCYAN;
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,2,(-1)),COLORGREEN;
HJ_90:=HJ_29 AND CROSS(HJ_26,HJ_27);
DRAWICON(HJ_90,HIGH,25);
HJ_91:=EMA(CLOSE,13);
DRAWICON(CROSS(CLOSE,HJ_91*1) AND (HJ_74 OR MA(CLOSE,5)>MA(CLOSE,10)),LOW*0.982,1);
HJ_92:=8;
HJ_93:=16;
HJ_94:=REF(HIGH,HJ_92)=HHV(HIGH,2*HJ_92+1);
HJ_95:=REF(HIGH,HJ_93)=HHV(HIGH,2*HJ_93+1);
HJ_96:=BACKSET(HJ_94,HJ_92+1);
HJ_97:=BACKSET(HJ_95,HJ_93+1);
HJ_98:=FILTER(HJ_96,HJ_92) AND HIGH=HHV(HIGH,HJ_92+1);
HJ_99:=FILTER(HJ_97,HJ_93) AND HIGH=HHV(HIGH,HJ_93+1);
HJ_100:=BARSLAST(HJ_98);
HJ_101:=BARSLAST(HJ_99);
HJ_102:=IF(HJ_98,CURRBARSCOUNT,0);
HJ_103:=IF(HJ_99,CURRBARSCOUNT,0);
HJ_104:=IF(HJ_100,REF(HJ_102,HJ_100),HJ_102);
HJ_105:=IF(HJ_101,REF(HJ_103,HJ_101),HJ_103);
HJ_106:=CONST(HJ_104);
HJ_107:=CONST(HJ_105);
HJ_108:=CONST(REF(HIGH,HJ_106-1));
HJ_109:=CONST(REF(HIGH,HJ_107-1));
HJ_110:=REF(HJ_104,HJ_100+1);
HJ_111:=REF(HJ_105,HJ_101+1);
HJ_112:=CONST(REF(HIGH,HJ_110-1));
HJ_113:=CONST(REF(HIGH,HJ_111-1));
HJ_114:=BACKSET(ISLASTBAR,HJ_110);
HJ_115:=BACKSET(ISLASTBAR,HJ_111);
HJ_116:=BACKSET(ISLASTBAR,HJ_106);
HJ_117:=BACKSET(ISLASTBAR,HJ_107);
CQ1:IF(HJ_114,HJ_112,DRAWNULL),DOTLINE,COLORRED;
CQ2:IF(HJ_116,HJ_108,DRAWNULL),DOTLINE,COLORYELLOW;
HJ_118:=IF(HJ_115,HJ_113,DRAWNULL);
HJ_119:=IF(HJ_117,HJ_109,DRAWNULL);
HJ_120:=(3*CLOSE+HIGH+LOW+OPEN)/6;
HJ_121:=(8*HJ_120+7*REF(HJ_120,1)+6*REF(HJ_120,2)+5*REF(HJ_120,3)+4*REF(HJ_120,4)+3*REF(HJ_120,5)+2*REF(HJ_120,6)+REF(HJ_120,8))/36;
HJ_122:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJ_121 AND CLOSE>REF(CLOSE,1);
HJ_123:=FILTER(HJ_122,5);
STICKLINE(HJ_123,OPEN,CLOSE,2,0),COLORYELLOW;
HJ_124:=IF(WINNER(CLOSE),WINNER(CLOSE)*100,0);
HJ_125:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
HJ_126:=COST(HJ_125);
HJ_127:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
HJ_128:=(CLOSE-OPEN)/OPEN*100>4;
HJ_129:=LOW<HJ_126 AND HJ_127;
HJ_130:=CROSS(CLOSE,HJ_126) AND HJ_127;
HJ_131:=LOW<HJ_126 AND HJ_128;
HJ_132:=HJ_129 OR HJ_130 OR HJ_131;
STICKLINE(HJ_132=1,CLOSE,OPEN,1.2,0),COLOR5789FF;
HJ_133:=CLOSE*VOL;
HJ_134:=EMA((EXPMA(HJ_133,1)/EXPMA(VOL,1)+EXPMA(HJ_133,2)/EXPMA(VOL,2)+EXPMA(HJ_133,4)/EXPMA(VOL,4)+EXPMA(HJ_133,6)/EXPMA(VOL,6))/4,7);
HJ_135:=EMA((EXPMA(HJ_133,3)/EXPMA(VOL,3)+EXPMA(HJ_133,6)/EXPMA(VOL,6)+EXPMA(HJ_133,12)/EXPMA(VOL,12)+EXPMA(HJ_133,24)/EXPMA(VOL,24))/4,13);
HJ_136:=EMA((EXPMA(HJ_133,27)/EXPMA(VOL,27)+EXPMA(HJ_133,54)/EXPMA(VOL,54)+EXPMA(HJ_133,108)/EXPMA(VOL,108)+EXPMA(HJ_133,316)/EXPMA(VOL,316))/4,13);
HJ_137:=1.3*HJ_135;
1.13*HJ_135,COLORRED;
HJ_138:=1.06*HJ_135;
HJ_139:=HJ_135*0.94;
HJ_140:=HJ_135*0.87;
HJ_141:=REF(CLOSE,1)*1.1-CLOSE<0.01 AND HIGH=CLOSE;
HJ_142:=CROSS(CLOSE,HJ_138) OR CROSS(CLOSE,HJ_139) AND HJ_141;
STICKLINE(HJ_142,CLOSE,OPEN,0.7,0),COLORGREEN;
启爆:CROSS(CLOSE,HJ_138) OR CROSS(CLOSE,HJ_139) AND HJ_141,NODRAW,COLORGREEN;
HJ_143:=(REF(HIGH,1)-MAX(REF(CLOSE,1),REF(OPEN,1)))/(REF(HIGH,1)-REF(LOW,1))>0.6 AND (MIN(OPEN,CLOSE)-LOW)/(HIGH-LOW)>0.6 AND VOL<REF(VOL,1);
DRAWICON(HJ_143,LOW,17);
HJ_144:=EMA(CLOSE,13);
HJ_145:=EMA(CLOSE,34);
HJ_146:=EMA(CLOSE,55);
HJ_147:=BARSLAST(BETWEEN(BIAS.BIAS2(6,13,24),0,5));
HJ_148:=HJ_144>HJ_145 AND HJ_145>HJ_146 AND HJ_144>REF(HJ_144,1);
HJ_149:=COUNT(BIAS.BIAS2(6,13,24)>10 AND HIGH=HHV(HIGH,HJ_147),HJ_147);
HJ_150:=HIGH=HHV(HIGH,HJ_147);
HJ_151:=MACD.MACD(12,26,9)<REF(MACD.MACD(12,26,9),1);
HJ_152:=HJ_148 AND HJ_149 AND HJ_150;
HJ_153:=HJ_148 AND HJ_149 AND HJ_150 AND HJ_151;
STICKLINE(HJ_152 AND HJ_153,HIGH,HIGH+0.09,4,0),COLORGREEN;
HJ_154:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
HJ_155:=IF(CLOSE>OPEN,HJ_154*(HIGH-LOW),IF(CLOSE<OPEN,HJ_154*(HIGH-OPEN+(CLOSE-LOW)),VOL/2));
HJ_156:=IF(CLOSE>OPEN,HJ_154*(HIGH-CLOSE+(OPEN-LOW)),IF(CLOSE<OPEN,HJ_154*(HIGH-LOW),VOL/2));
HJ_157:=HJ_155/HJ_156;
抢筹:HJ_157,NODRAW,COLORFF55FF;
获利%:MA(WINNER(1.001*CLOSE)*100-WINNER(COST(0))*100,1),NODRAW,COLORWHITE;
SC:(WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*100,NODRAW,COLORGREEN;
主筹:EMA(WINNER(CLOSE)*70,3),NODRAW,COLORMAGENTA;
HJ_158:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
HJ_159:=HJ_158/(主筹+HJ_158)*100;
HJ_160:=主筹/(主筹+HJ_158)*100;
散筹:INTPART(HJ_159),NODRAW,COLORGREEN;
控盘:INTPART(HJ_160),NODRAW,COLORRED;
HJ_161:=EMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,6)-LLV(LOW,6)),2)*100;
HJ_162:=SMA(SMA(HJ_161,2,1),2,1);
HJ_163:=(HJ_162/2+36.799999)*1;
HJ_164:=SMA(HJ_163,2,1)+2.2;
HJ_165:=SMA(HJ_163,2,1)-35.080002;
DRAWICON(CROSS(HJ_164,HJ_161*0.9998+0.0018) AND HJ_164>67 AND 牛线<REF(牛线,1),HIGH,2);
DRAWTEXT(CROSS(HJ_161,HJ_165*0.9998+0.0018),LOW-0.01,35),COLORMAGENTA;

{-----------------------------------}

推荐下载

赞助商广告