加入收藏
 

通达信指标 源码分享 强者恒强

2018-05-15 10:13:19推荐星级:下载统计()
奇爱股票网提供通达信指标 源码分享 强者恒强下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

通达信指标 源码分享 强者恒强说明

{公式名称: 强者恒强
公式描述:
无参数
公式类型: 技术指标公式-其他类型
画线方法: 主图叠加
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
生命:=(3*CLOSE+OPEN+LOW+HIGH)/6;
生命A:(20*生命+19*REF(生命,1)+18*REF(生命,2)+17*REF(生命,3)+16*REF(生命,4)+15*REF(生命,5)+14*REF(生命,6)+13*REF(生命,7)+12*REF(生命,8)+11*REF(生命,9)+10*REF(生命,10)+9*REF(生命,11)+8*REF(生命,12)+7*REF(生命,13)+6*REF(生命,14)+5*REF(生命,15)+4*REF(生命,16)+3*REF(生命,17)+2*REF(生命,18)+REF(生命,20))/210,COLORFFFFFF LINETHICK3;
生命B:MA(生命A,5),COLOR00FFFF LINETHICK3;
DRAWBAND(生命A,RGB(178,34,34),生命B,RGB(11,150,30));
M1:=CROSS(生命A,生命B);
DRAWICON(M1,(20*生命+19*REF(生命,1)+18*REF(生命,2)+17*REF(生命,3)+16*REF(生命,4)+15*REF(生命,5)+14*REF(生命,6)+13*REF(生命,7)+12*REF(生命,8)+11*REF(生命,9)+10*REF(生命,10)+9*REF(生命,11)+8*REF(生命,12)+7*REF(生命,13)+6*REF(生命,14)+5*REF(生命,15)+4*REF(生命,16)+3*REF(生命,17)+2*REF(生命,18)+REF(生命,20))/210,11);
M2:=CROSS(生命B,生命A);
DRAWICON(M2,MA(生命A,5),12);
持股:=生命A>生命B,LINETHICK2,NODRAW;
STICKLINE(持股,H,L,0,0)COLOR0000FF NODRAW;
STICKLINE(持股,O,C,2,0)COLOR0000FF NODRAW;
持币:=生命B>生命A,LINETHICK2,NODRAW;
STICKLINE(持币,H,L,0,0)COLOR008000 NODRAW;
STICKLINE(持币,O,C,2,0)COLOR008000 NODRAW;

完全强势:MA(LOW,20)*1.2,COLOR00FFFF,LINETHICK2 NODRAW;
进入强势:MA(LOW,20)*1.1,COLOR0000FF LINETHICK2 NODRAW;
进入弱势:MA(HIGH,20)*0.9,COLORFFFF00 LINETHICK2 NODRAW;
完全弱势:MA(HIGH,20)*0.8,COLORFF0000,LINETHICK2 NODRAW;
ZD:=(C-REF(C,1))/REF(C,1)*100;
HDZF:=(HHV(H,20)-C)/(HHV(H,20)-LLV(L,20));
趋势强度:=IF(C>进入强势,IF(C>完全强势,4,3),IF(C>进入弱势 AND C<进入强势,2,IF(C<完全弱势,0,1)));
STICKLINE(趋势强度=0,H,L,0,1),COLORBLUE;
STICKLINE(趋势强度=0,C,O,2,0),COLORBLUE;
STICKLINE(趋势强度=1,H,L,0,1),COLORFFFF00;
STICKLINE(趋势强度=1,C,O,2,0),COLORFFFF00;
STICKLINE(趋势强度=2,H,L,0,1),COLORGRAY;
STICKLINE(趋势强度=2,C,O,2,0),COLORGRAY;
STICKLINE(趋势强度=3,H,L,0,1),COLOR0000FF;
STICKLINE(趋势强度=3,C,O,2,0),COLOR0000FF;
STICKLINE(趋势强度=4,H,L,0,1),COLOR00FFFF;
STICKLINE(趋势强度=4,C,O,2,0),COLOR00FFFF;

{常规提示}
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,DYBLOCK)COLORFFFFFF;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.05,0,GNBLOCK)COLORFFFFFF;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.10,0,FGBLOCK)COLORFFFFFF;

推荐下载

赞助商广告