加入收藏
 

通达信指标 源码分享 大阴战法主图

2018-05-15 10:11:06推荐星级:下载统计()
奇爱股票网提供通达信指标 源码分享 大阴战法主图下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

通达信指标 源码分享 大阴战法主图说明

HJ_1:=DATE<=1151210;
HJ_2:=N1;
HJ_3:=5;
周期:CURRBARSCOUNT,NODRAW,COLORGREEN;
HJ_4:=周期-1;
HJ_5:=IF(HJ_1,CLOSE/REF(CLOSE,1)<=1-HJ_2/100 AND OPEN>=CLOSE,DRAWNULL);
HJ_6:=REFX(CLOSE,HJ_4);
HJ_7:=REFX(HIGH,HJ_4);
HJ_8:=REFX(OPEN,HJ_4);
HJ_9:=REFX(LOW,HJ_4);
HJ_10:=BARSLAST(HJ_5 AND CLOSE>=HJ_8 AND 周期>=HJ_3);
HJ_11:=REFX(REF(OPEN,HJ_10),HJ_4);
HJ_12:=REFX(REF(CLOSE,HJ_10),HJ_4);
HJ_13:=REFX(REF(周期,HJ_10),HJ_4);
HJ_14:=周期>HJ_13;
压力顶:IF(HJ_14,DRAWNULL,HJ_11),DOTLINE,COLORGREEN;
压力底:IF(HJ_14,DRAWNULL,HJ_12),DOTLINE,COLORGREEN;
HJ_15:=BARSLAST(HJ_5 AND OPEN>=HJ_8 AND 周期>=HJ_3);
HJ_16:=REFX(REF(OPEN,HJ_15),HJ_4);
HJ_17:=REFX(REF(CLOSE,HJ_15),HJ_4);
HJ_18:=REFX(REF(周期,HJ_15),HJ_4);
HJ_19:=周期>HJ_18;
震荡顶:IF(HJ_19,DRAWNULL,HJ_16),DOTLINE,COLORMAGENTA;
震荡底:IF(HJ_19,DRAWNULL,HJ_17),DOTLINE,COLORMAGENTA;
HJ_20:=BARSLAST(HJ_5 AND OPEN<=HJ_8 AND 周期>=HJ_3);
HJ_21:=REFX(REF(OPEN,HJ_20),HJ_4);
HJ_22:=REFX(REF(CLOSE,HJ_20),HJ_4);
HJ_23:=REFX(REF(周期,HJ_20),HJ_4);
HJ_24:=周期>HJ_23;
支撑顶:IF(HJ_24,DRAWNULL,HJ_21),DOTLINE,COLORLIRED;
支撑底:IF(HJ_24,DRAWNULL,HJ_22),DOTLINE,COLORLIRED;
HJ_25:=CLOSE/REF(CLOSE,1)>=1.099 AND CLOSE=HIGH AND HJ_1;
STICKLINE(HJ_25,OPEN,CLOSE,(-1),0),COLORMAGENTA;
HJ_26:=CLOSE/REF(CLOSE,1)<=0.901 AND LOW=CLOSE AND HJ_1;
STICKLINE(HJ_26 AND OPEN/CLOSE>1.007,OPEN,CLOSE*1.005,(-1),0),COLORLIBLUE;
DRAWTEXT(ISLASTBAR,HJ_16,VAR2STR(HJ_16,2)),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,HJ_21,VAR2STR(HJ_21,2)),COLORLIRED;
DRAWTEXT(ISLASTBAR,HJ_11,VAR2STR(HJ_11,2)),COLORGREEN;
DRAWTEXT(ISLASTBAR,HJ_17,VAR2STR(HJ_17,2)),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,HJ_22,VAR2STR(HJ_22,2)),COLORLIRED;
DRAWTEXT(ISLASTBAR,HJ_12,VAR2STR(HJ_12,2)),COLORGREEN;
HJ_27:=0;
HJ_28:=0.8;
HJ_29:=STRCAT(STRSPACE(DYBLOCK),STRSPACE(HYBLOCK));
DRAWTEXT_FIX(ISLASTBAR,HJ_28,HJ_27,0,HJ_29),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,HJ_28,HJ_27+0.03*1,0,GNBLOCK),COLORLIMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,HJ_28,HJ_27+0.03*2,0,STKNAME),COLORGREEN;
{-----------------------------------}

推荐下载

赞助商广告