加入收藏
 

通达信指标 源码分享 独霸牛熊

2018-05-02 09:29:33推荐星级:下载统计()
奇爱股票网提供通达信指标 源码分享 独霸牛熊下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

通达信指标 源码分享 独霸牛熊说明

X_1:=PERIOD=5 AND CLOSE>0 AND VOL>1;
X_2:=1;
X_3:=EMA(EMA(CLOSE,9),9);
X_4:=(X_3-REF(X_3,1))/REF(X_3,1)*1000;
X_5:=EMA(EMA(CLOSE,8),8);
X_6:=(X_5-REF(X_5,1))/REF(X_5,1)*1000;
X_7:=X_6>0;
X_8:=X_6<=0;
X_9:=EMA(CLOSE,2);
X_10:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);
X_11:=CROSS(X_9,X_10);
X_12:=CROSS(X_10,X_9);
X_13:=IF(X_11 AND X_7,1,IF(COUNT(X_11 AND X_8,BARSLAST(X_12)+1)=1 AND CROSS(X_6,0),1,0));
X_14:=X_13 AND COUNT(X_13,BARSLAST(X_12)+1)=1;
X_15:=X_12 AND COUNT(X_12,BARSLAST(X_14)+1)=1;
X_16:=X_14;
X_17:=CLOSE/REF(OPEN,BARSLAST(X_14))<1-7/100 AND COUNT(X_14,BARSLAST(X_14)+1)=1 AND COUNT(X_15,BARSLAST(X_14)+1)=0;
X_18:=IF(X_17 AND COUNT(X_17,BARSLAST(X_14)+1)=1,1,IF(X_15 AND COUNT(X_17,BARSLAST(X_14)+1)=0,1,0));
X_19:=COUNT(X_17,BARSLAST(X_16)+1)>=1 AND CROSS(CLOSE,0.965*REF(OPEN,BARSLAST(X_16)));
X_20:=(X_19 AND X_18)=0;
X_21:=X_16 AND COUNT(X_18,X_2)=0 OR X_19 AND X_20;
X_22:=CLOSE/REF(OPEN,BARSLAST(X_19))<1-7/100 AND COUNT(X_19,BARSLAST(X_19)+1)=1 AND COUNT(X_15,BARSLAST(COUNT(X_19,BARSLAST(X_19)+1))+1)=0;
X_23:=X_15 AND COUNT(X_19,BARSLAST(X_21)+1)=1 OR (X_22 AND SUM(X_22,0)=1);
X_24:=(X_23 AND X_21)=0;
X_25:=X_18 AND COUNT(X_18,BARSLAST(X_21)+1)=1 OR X_23 AND X_24;
X_26:=X_21 AND COUNT(X_21,BARSLAST(X_25)+1)=1;
X_27:=X_25 AND COUNT(X_25,BARSLAST(X_26)+1)=1;
X_28:=IF(COUNT(X_27,BARSCOUNT(CLOSE))=0 AND COUNT(X_26,BARSCOUNT(CLOSE))=0,1,0);
X_29:=X_28 AND CROSS(X_4,0);
X_30:=IF(X_28,X_29,X_26);
X_31:=X_30 AND X_1;
X_32:=MA(CLOSE,5);
X_33:=MA(CLOSE,10);
X_34:=MA(CLOSE,30);
X_35:=MA(CLOSE,60);
X_36:=EMA(CLOSE,5);
X_37:=EMA(CLOSE,6);
X_38:=DRAWLINE(LOW=LLV(LOW,BARSLAST(CROSS(X_37,X_36))+1),LLV(LOW,BARSLAST(CROSS(X_37,X_36))+1),HIGH=HHV(HIGH,BARSLAST(CROSS(X_36,X_37))+1),HHV(HIGH,BARSLAST(CROSS(X_36,X_37))+1),0);
X_39:=(2*CLOSE+HIGH+LOW)/4;
X_40:=LLV(X_39,21);
X_41:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
X_42:=REF(X_41,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_43:=REF(X_42,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_44:=REF(X_43,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_45:=REF(X_44,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_46:=REF(X_45,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_47:=REF(X_46,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_48:=REF(X_47,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_49:=REF(X_48,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_50:=REF(X_49,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_51:=REF(X_50,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_52:=REF(X_51,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_53:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
X_54:=REF(X_53,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_55:=REF(X_54,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_56:=REF(X_55,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_57:=REF(X_56,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_58:=REF(X_57,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_59:=REF(X_58,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_60:=REF(X_59,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_61:=REF(X_60,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_62:=REF(X_61,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_63:=REF(X_62,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
X_64:=REF(X_63,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
X_65:=REF(X_53 OR X_54 OR X_55 OR X_56 OR X_57 OR X_58 OR X_59 OR X_60 OR X_61 OR X_62 OR X_63 OR X_64,1) AND X_41;
X_66:=REF(X_41 OR X_42 OR X_43 OR X_44 OR X_45 OR X_46 OR X_47 OR X_48 OR X_49 OR X_50 OR X_51 OR X_52,1) AND X_53;
X_67:=(HIGH+LOW+CLOSE)/3;
X_68:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
X_69:=ABS(X_68*(X_67-MIN(CLOSE,OPEN)));
X_70:=ABS(X_68*(MIN(OPEN,CLOSE)-LOW));
X_71:=X_69;
X_72:=-X_70;
X_73:=X_71-ABS(X_72)>X_71*0.5;
XG:X_73 AND X_38 AND X_65 OR (X_73 AND X_38 AND X_31);
 

推荐下载

赞助商广告