加入收藏
 

同花顺指标 源码分享 做多做空+短中长KDJ

2018-07-24 09:31:34推荐星级:下载统计()
奇爱股票网提供同花顺指标 源码分享 做多做空+短中长KDJ下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

同花顺指标 源码分享 做多做空+短中长KDJ说明

VAR1:=1;

VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3*VAR1;
VAR5:=REF(LLV(CLOSE,480),1)*VAR1;
VAR6:=REF(HHV(CLOSE,480),1)*VAR1;
VAR7:=100*(CLOSE-VAR5)/(VAR6-VAR5)*VAR1;
VAR8:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100*VAR1;
VAR9:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100*VAR1;
VARA:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100*VAR1;
VARB:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100*VAR1;
VARC:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5)/4*VAR1;
VARD:=IF(VARC>23.16,VARC,0)*VAR1;
VARE:=VARC<1*VAR1;
VARF:=VARD*VAR1;
VAR10:=VAR4<0 AND VAR7<0;
VAR11:=1;
VAR12:=(HIGH+LOW+CLOSE*2)/4*VAR11;
VAR13:=EMA(VAR12,21);
VAR14:=STD(VAR12,21);
VAR15:=((VAR12-VAR13)/VAR14*100+200)/4*VAR11;
VAR16:=(EMA(VAR15,89)-25)*1.56*VAR11;
VAR17:=EMA(VAR16,5)*1.22*VAR11;
VAR18:=EMA(VAR17,3)*VAR11;
VAR19:=3*VAR17-2*VAR18*VAR11;
VAR1A:=IF(CROSS(VAR19,VAR17) AND CROSS(VAR19,VAR18) AND CROSS(VAR17,VAR18),1,0);
VAR1B:=IF(CROSS(VAR17,VAR19) AND CROSS(VAR18,VAR19) AND CROSS(VAR18,VAR17),1,0);
VAR1C:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4*VAR1;
VAR1D:=EMA(CLOSE,2)-EMA(CLOSE,89)*VAR1;
VAR1E:=EMA(VAR1D,30)*VAR1;
VAR1F:=2*(VAR1D-VAR1E)*10*VAR1;
VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2)*VAR1;
VAR21:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR22:=EMA(VAR21*0.97,3)*VAR1;
VAR23:=(HIGH+LOW+CLOSE)/3*VAR1;
VAR24:=(VAR23-MA(VAR23,14))/(0.015*AVEDEV(VAR23,14))*VAR1;
VAR25:=IF(VAR1F>0.015,VAR20,0)/45*VAR1;
拉升: VAR25,COLORFF00FF,LINETHICK2;
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
VAR2A:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR2B:=EMA(VAR2A*0.97,3);
VAR2C:=(HIGH+LOW+CLOSE)/3;
VAR2D:=(VAR2C-MA(VAR2C,14))/(0.015*AVEDEV(VAR2C,14));
主力:IF(VAR28>0.1,VAR29,0)*5,LINETHICK2,coloryellow;
买点:=IF(FILTER(VAR8=0 AND VARE AND VAR10 AND VAR1A,5)=1,10,0),colorcyan;
DRAWTEXT(CROSS(拉升,0.001)AND 主力>0,拉升,"买"),colorwhite;
卖点:=IF(FILTER(VAR8=100 AND VARF AND VAR1B,5)=1,10,0),colorgreen;
零层:0, linethick1,colorwhite;
RSV=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
a=SMA(RSV,M1,1);
b=SMA(a,M2,1);
e=3*a-2*b;
IF(a<0) a=0;
IF(a>100) a=100;
IF(b<0) b=0;
IF(b>100) b=100;
IF(e<0) e=0;
IF(e>100) e=100;
K:a;
D:b;
J短:e,Linethick2;
RSV=(CLOSE-LLV(LOW,N2))/(HHV(HIGH,N2)-LLV(LOW,N2))*100;
a=SMA(RSV,M12,1);
b=SMA(a,M22,1);
e=3*a-2*b;
IF(a<0) a=0;
IF(a>100) a=100;
IF(b<0) b=0;
IF(b>100) b=100;
IF(e<0) e=0;
IF(e>100) e=100;
J中:e;
RSV=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
a=SMA(RSV,M13,1);
b=SMA(a,M23,1);
e=3*a-2*b;
IF(a<0) a=0;
IF(a>100) a=100;
IF(b<0) b=0;
IF(b>100) b=100;
IF(e<0) e=0;
IF(e>100) e=100;
J长:e,Linethick2,coloryellow;
J翘头:IF(CROSS(J短,1),18,0),colorgray,LINETHICK2;
DRAWTEXT(CROSS(J翘头,1),25,'J翘头'),coloryellow,LINETHICK1;
J短买区:IF((主力>0 OR 拉升>0 AND J中>=0 AND J中<32 AND J短 >=0 AND J短<72),-10,0),colormagenta,LINETHICK2;
DRAWTEXT (CROSS(J短买区,1),11,''),colorcyan,LINETHICK2;
J中买区:IF((主力>0 OR 拉升>0 AND J长>=0 AND J长<3 AND J中>0 AND J中<81),-8,0),colorwhite,LINETHICK2;
J长买区:IF((主力>0 OR 拉升>0 AND J长>=0 AND J长<3 AND J中>=0 AND J中<32 AND J短 >=0 AND J短<72),-8,0),coloryellow,LINETHICK1;
底层:0, linethick0,colorred;
顶层:100,linethick0,colorgreen;
近底层:2,linethick1;
一层:10,linethick1;
二层:20,linethick1;
三层:30,linethick1;
八层:80,linethick1;
九层:90,linethick1;
近顶层:97,Linethick1;

推荐下载

赞助商广告