加入收藏
 

同花顺指标 源码分享 底建顶清

2018-07-18 09:30:36推荐星级:下载统计()
奇爱股票网提供同花顺指标 源码分享 底建顶清下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

同花顺指标 源码分享 底建顶清说明

B:ZIG(3,10),coloryellow;

G:=MA(B,2),colorred;
D:=EMA(B,34),colorgreen;
J:=EMA(B,144),colorligreen;
DRAWICON(CROSS(B,G),B-0.1,1);
DRAWICON(CROSS(G,B),G+0.1,2);
//DRAWTEXT(CROSS(B,G),B*0.85,"建"),coloryellow;
//DRAWTEXT(CROSS(G,B),G,"清"),colorgreen;
F:=100*(C-REF(C,1))/REF(C,1);
JD:=IF(C<REF(O,1) AND F<0,1,0);
S1:=JD;
MR:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0;
S2:=MR;
A1:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1));
A2:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,5) ,REF(ZIG(3 ,5),1));
//DRAWTEXT(A1 AND A2 OR D<0,B,'加仓'),coloryellow;//加仓买
//DRAWICON(A1 AND A2,B-0.2,1);
VAR3:=PEAKBARS(3,5,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);
顶A:=IF(顶>REF(顶,1),1,0),STICK,colorcyan, LINETHICK2;//
//DRAWTEXT(顶A=1,B*1.1,'减仓'),colorgreen;
DRAWICON(顶A=1,B,2);
A11:LLV(LOW,144),colormagenta;
A12:HHV(CLOSE,13),colorwhite;
//DRAWICON(A11==REF(A11,1) AND REF(A11,1)<REF(A11,2),A11,1);
//DRAWICON(A11<REF(A11,1) AND REF(A11,1)==REF(A11,2),A11,2);
//DRAWICON(A11>REF(A11,1) AND REF(A11,1)==REF(A11,2),A11,1);
MID:=MA(CLOSE,26);
UPPER:=MID + 2*STD(CLOSE,26),colorwhite;//上轨
UPPER1:=MID + 1.618*STD(CLOSE,26),colorred;//上轨
LOWER:=MID - 2*STD(CLOSE,26),coloryellow;//下轨
LOWER1:=MID - 1.618*STD(CLOSE,26),colorgreen;//下轨
//DRAWTEXT(CROSS(CLOSE,LOWER),J*1.05,"L"),coloryellow;;
//DRAWTEXT(CROSS(CLOSE,UPPER),J*1.05,"L"),colorgreen;
DRAWICON(CROSS(B,A11),B,1);
DRAWICON(CROSS(A11,B),B,2);
DRAWICON(CROSS(B,A12),A12,1);
VERLINE(CROSS(B,G) AND (A1 AND A2 OR D<0),1),colorlimagenta;//画加仓建仓垂线
VERLINE(CROSS(G,B),1),colorcyan;//画清仓垂线
STICKLINE(A11<B AND B>REF(B,1),B,A11,0.8,0),colorred;
STICKLINE(A11<B AND B<REF(B,1),B,A11,0.8,0),colorgreen;
STICKLINE(B==A12,B,A11,0.8,0),colorgreen;
DRAWTEXT(B==A12,A12*1.15,"S"),colorgreen;
DRAWTEXT((CROSS(B,G) AND (A1 AND A2 OR D<0)) OR CROSS(B,G),A11*0.95,'B'),coloryellow;//建仓加仓买
STICKLINE(A11>B AND B>REF(B,1),B,A11,0.8,0),colorred;
STICKLINE(A11>B AND B<REF(B,1),B,A11,0.8,0),colorgreen;
DRAWTEXT(REF(顶A=1,1) AND CROSS(G,B),A12*1.15,"清仓"),colorgreen;
//DRAWTEXT(A1 AND A2 OR D<0,B,'加仓'),coloryellow;//加仓买
DRAWTEXT(CROSS(MA(INDEXC,5),MA(INDEXC,13)),A11,"D513"),coloryellow;
DRAWTEXT(CROSS(MA(INDEXC,13),MA(INDEXC,5)),B*1.05,"D513"),colorgreen;
//X:=INTPART(CLOSE/(INDEXC/1000));
XO:=TOSTRING(OPEN/(INDEXC/1000),0);
XH:=TOSTRING(HIGH/(INDEXC/1000),0);
XL:=TOSTRING(LOW/(INDEXC/1000),0);
XC:=TOSTRING(CLOSE/(INDEXC/1000),0);
DOO:=(INDEXO/1000)*XO;
DH:=(INDEXH/1000)*XH;
DL:=(INDEXL/1000)*XL;
DC:=(INDEXC/1000)*XC;
DRAWKLINE(DH,DOO,DL,DC);//大盘K线
D5:MA(DC,5),colormagenta;
D13:MA(DC,13),colorcyan;
DRAWICON(CROSS(D5,D13),D5,1);
DRAWICON(CROSS(D13,D5),D5,2);
//DRAWKLINE(H,O,L,C);//K线

推荐下载

赞助商广告