加入收藏
 

同花顺指标 源码分享 道本管家

2018-07-09 10:22:38推荐星级:下载统计()
奇爱股票网提供同花顺指标 源码分享 道本管家下载,更多精品通达信 大智慧 同花顺 飞狐股票公式 常用股票软件下载请登录www.72gu.com下载!
0
返回首页下载特效 需要: 积分

同花顺指标 源码分享 道本管家说明

DRAWTEXT_FIX(C>O,0.35,0.01,0,' ★★★一本制作╬管家,滥用责任自负★★★ '),colorred;

TR:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) );
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);
短趋线:(((DMP ) * 100) / TR),LINETHICK3,COLORFF8000;
辅助线:=((DMM * 100) / TR);
动向趋势线:=(MA(((ABS((辅助线 - 短趋线)) / (辅助线 + 短趋线)) * 100),3));
ADXR:=((动向趋势线 + REF(动向趋势线,3)) / 2);
VAR1:=MA(LOW,1);
VAR2:=MA(HIGH,2);
VAR3:=MA(CLOSE,2);
VAR7:=REF(VAR3,1);
预警:(IF(((动向趋势线 > 88) AND (短趋线 < 5.8)),20,0) ),LINETHICK1,COLOR8080FF;
FILLRGN(短趋线,5,短趋线<=5,RGB(255,0,0));
FILLRGN(短趋线,43,短趋线>=43,RGB(250,250,0));
FILLRGN(短趋线,60,短趋线>=60,colorgreen);
阿门1:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
阿门2:=SMA(阿门1,13,8);
耶稣传道:=CEILING(SMA(阿门2,13,8));
耶稣说道:=MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5);
阿门3:=BARSLAST(REF(CROSS(耶稣传道,耶稣说道),1));
阿门4:=REF(C,阿门3+1)>C AND REF(耶稣传道,阿门3+1)<耶稣传道 AND CROSS(耶稣传道,耶稣说道);
阿门6:=(HIGH+LOW+CLOSE+OPEN)/4;
阿门7:=(阿门6-MA(阿门6,14))/(0.015*AVEDEV(阿门6,14));
阿门8:=(阿门6-MA(阿门6,70))/(0.015*AVEDEV(阿门6,70));
阿门9:=IF(阿门7>=150 AND 阿门7<200 AND 阿门8>=150 AND 阿门8<200,10,0);
阿门10:=IF(阿门7<=-150 AND 阿门7>-200 AND 阿门8<=-150 AND 阿门8>-200,-10,阿门9);
中位:(IF(阿门8>=200 AND 阿门7>=150,15,IF(阿门8<=-200 AND 阿门7<=-150,-15,阿门10))+50),colorcc9900 ,linethick1 ,CROSSDOT;
B1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70;
B2:=SMA(B1,9,1)+100;
B3:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
一本管家:IF(B6>60,B6-60,0),LINETHICK3,colormagenta;
持有:STICKLINE(REF(一本管家,1)<一本管家,一本管家,REF(一本管家,1),5,0),colormagenta;
HLM1:=MA(HHV(H,485),17);
HLM2:=MA(HHV(H,222),17);
HLM3:=MA(HHV(H,96),17);
HLM4:=MA(LLV(L,485),17);
HLM5:=MA(LLV(L,222),17);
HLM6:=MA(LLV(L,96),17);
HLM7:=MA((HLM1*0.558+HLM2*0.558+HLM3*0.558+HLM4*0.96+HLM5*0.96+HLM6*0.96)/6,17);
HLM8:=MA((HLM1*0.55+HLM2*0.55+HLM3*0.65+HLM4*1.25+HLM5*1.23+HLM6*1.2)/6,17);
HLM9:=MA((HLM1*0.68+HLM2*0.68+HLM3*0.68+HLM4*1.3+HLM5*1.3+HLM6*1.3)/6,17);
HLM10:=MA((HLM7*3+HLM8*2+HLM9)/6*1.738,17);
HLM11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
HLM12:=MA(IF(C*1.35<=HLM10,HLM11*10,HLM11/10),3);
HLMH:=HHV(HLM12,30);
关注:=MA(IF(L<=LLV(L,13),(HLMH+HLM11*2)/2,0),3)/200;
VAR82:=LLV(LOW,10);
VAR83:=HHV(HIGH,25);
使唤线: 48,colorcyan;
撬边线: 53,colorwhite;
开门线: 40,LINETHICK3,colorred;
底线: 0.2,LINETHICK1,colorlicyan;
动力线: EMA((CLOSE-VAR82)/(VAR83-VAR82)*60,4),LINETHICK1,colorligreen;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(VAR3*10,3);
VAR5:=LLV(LOW,13);
VAR6:=HHV(VAR4,13);
VAR7:=IF(BARPOS>34,1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=-IF(VAR8>100,100,VAR8);
DRAWICON(CROSS(一本管家,动力线) ,一本管家,11);
DRAWICON(CROSS(一本管家,开门线) ,一本管家,9);
DRAWICON(CROSS(一本管家,底线) ,一本管家,25);
 

推荐下载

赞助商广告